Nexis Hosting - Nexis Hosting - Global - Upstream Maintenance - July 23rd, 2025 – Incident details

Experiencing partial outage

Nexis Hosting - Global - Upstream Maintenance - July 23rd, 2025

Resolved
Under maintenance
Started 5 months agoLasted 27 minutes

Affected

Network Services (US)

Path.net (Remote Protection Provider) → North America → Chicago, Illinois

Nexis Hosting → Premium VPS

Chicago, Illinois Data Center → Cogent Communications (Internet Carrier)

Updates
  • Resolved
    Resolved

    Maintenance has been completed successfully

  • Monitoring
    Monitoring
    Please refer to a very important maintenance announcement that may have an impact on hosting services: **Nexis Hosting - Global - Upstream Maintenance - July 23rd, 2025** **Locations Affected:** Chicago, Illinois **Start Date:** July 23rd, 2025 @ 13:00 UTC **Estimated End Date:** July 23rd, 2025 @ 15:00 UTC **Summary:** Path, one of our DDoS protection providers, is performing updates to critical BGP routing sessions in select PoPs (points-of-presence). We apologize for the short notice and inconvenience. We were notified \~4 hours before the maintenance is scheduled to take place. **Impact on Customer:** Disruptions are expected to be minimal and short-lived. As a result, we will be moving Chicago Path-routed traffic before the maintenance window to our on-site filtering appliances. Our team will be monitoring throughout the maintenance. We apologize for the inconvenience. **Updates:** We will provide updates via our status page throughout the maintenance. You can subscribe to alerts on our status page ([**https://status.nexishosting.com**](https://status.infraly.co)). If you have any questions, don't hesitate to contact our client relations team via support ticket. Thank you again for your cooperation and support! Sincerely, Nexis Hosting, a division of Stormnet Hosting LTD a: 603 Discovery Drive, West Chicago, IL, USA e: [**hello@nexishosting.com**](mailto:hello@infraly.co) w: [**stormnethosting.com**](https://stormnethosting.com) **/** [**nexishosting.com**](https://nexishosting.com)